项目

一般

简介

插件 » Redmine My Page Paginations 我的工作台分页器

Redmine My Page Paginations

发布于: https://github.com/HugoHasenbein/redmine_my_page_paginations
兼容于: Redmine 5.1.*, 5.0.*, 4.2.*, 4.1.*

最新版本: 1.0.3_1 更新日期: 2024-01-30 13:11

评论

添加评论

gu zhandong大约一个月 之前添加

修复了5.x 的兼容错误
config.active_record.yaml_column_permitted_classes << IssueStatus
^^
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/craftmine/patches/permitted_classes_patch.rb:5:in `block in <module:PermittedClassesPatch>'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/railtie.rb:234:in `instance_eval’
/usr/local/bundle/gems/railties-6.1.6/lib/rails/railtie.rb:234:in `configure’

链接: https://pan.baidu.com/s/1MtpzyYzd2nvQ2qzMY70Chw?pwd=vqx2 提取码: vqx2 复制这段内容后打开百度网盘手机App,操作更方便哦

尹 先生4 个月 之前添加

这个10积分要10元钱,有点贵啊

redmineplugins.cn Admin超过一年 之前添加

1.0.2_1修复了不兼容redmine5的问题

z j5 个月 之前添加

@redmineplugins.cn Admin 您好 我下载安装后报了一个这样的问题
rake aborted!
NoMethodError: undefined method `<<' for nil:NilClass

config.active_record.yaml_column_permitted_classes << IssueStatus
^^
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/craftmine/patches/permitted_classes_patch.rb:5:in `block in &lt;module:PermittedClassesPatch&gt;'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/railtie.rb:234:in `instance_eval'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/railtie.rb:234:in `configure'
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/craftmine/patches/permitted_classes_patch.rb:4:in `&lt;module:PermittedClassesPatch&gt;'
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/craftmine/patches/permitted_classes_patch.rb:3:in `&lt;module:Patches&gt;'
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/craftmine/patches/permitted_classes_patch.rb:2:in `&lt;module:Craftmine&gt;'
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/craftmine/patches/permitted_classes_patch.rb:1:in `&lt;top (required)&gt;'
/usr/local/bundle/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/usr/local/bundle/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/usr/local/bundle/gems/zeitwerk-2.6.0/lib/zeitwerk/kernel.rb:35:in `require'
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/craftmine.rb:2:in `&lt;top (required)&gt;'
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/redmine_my_page_paginations.rb:22:in `require_relative'
/usr/src/redmine/plugins/redmine_my_page_paginations/lib/redmine_my_page_paginations.rb:22:in `&lt;top (required)&gt;'
/usr/local/bundle/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/usr/local/bundle/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/usr/local/bundle/gems/zeitwerk-2.6.0/lib/zeitwerk/kernel.rb:27:in `require'
/usr/src/redmine/plugins/redmine_my_page_paginations/init.rb:38:in `&lt;top (required)&gt;'
/usr/src/redmine/lib/redmine/plugin_loader.rb:31:in `load'
/usr/src/redmine/lib/redmine/plugin_loader.rb:31:in `run_initializer'
/usr/src/redmine/lib/redmine/plugin_loader.rb:108:in `each'
/usr/src/redmine/lib/redmine/plugin_loader.rb:108:in `block in load'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:427:in `instance_exec'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:427:in `block in make_lambda'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:198:in `block (2 levels) in halting'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:604:in `block (2 levels) in default_terminator'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:603:in `catch'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:603:in `block in default_terminator'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:199:in `block in halting'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:512:in `block in invoke_before'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:512:in `each'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:512:in `invoke_before'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/callbacks.rb:105:in `run_callbacks'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/reloader.rb:88:in `prepare!'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/application/finisher.rb:124:in `block in &lt;module:Finisher&gt;'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/initializable.rb:32:in `instance_exec'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/initializable.rb:32:in `run'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/initializable.rb:61:in `block in run_initializers'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/initializable.rb:60:in `run_initializers'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/application.rb:391:in `initialize!'
/usr/src/redmine/config/environment.rb:16:in `&lt;top (required)&gt;'
/usr/local/bundle/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/usr/local/bundle/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/usr/local/bundle/gems/zeitwerk-2.6.0/lib/zeitwerk/kernel.rb:35:in `require'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/dependencies.rb:332:in `block in require'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/dependencies.rb:299:in `load_dependency'
/usr/local/bundle/gems/activesupport-6.1.6/lib/active_support/dependencies.rb:332:in `require'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/application.rb:367:in `require_environment!'
/usr/local/bundle/gems/railties-6.1.6/lib/rails/application.rb:533:in `block in run_tasks_blocks'
Tasks: TOP => db:migrate => db:load_config => environment
(See full trace by running task with --trace)
W, [2024-01-29T19:13:40.458824 #86] WARN -- : Creating scope :system. Overwriting existing method Enumeration.system.

guo hongxing5 个月 之前添加

z j 请提供你详细的redmine版本,redmine_my_page_paginations-1.0.2_1在redmine 5.1.1测试正常。

Environment:
  Redmine version                5.1.1.stable.22587
  Ruby version                   3.1.4-p223 (2023-03-30) [arm64-darwin22]
  Rails version                  6.1.7.6
  Environment                    development
  Database adapter               Mysql2
  Mailer queue                   ActiveJob::QueueAdapters::AsyncAdapter
  Mailer delivery                smtp
Redmine settings:
  Redmine theme                  Jizhou (includes JavaScript)
SCM:
  Subversion                     1.14.2
  Git                            2.39.2
  Filesystem                     
Redmine plugins:
  custom_field_sql               2.6
  issue_charts                   1.3.0_3
  redmine_backup                 0.0.1
  redmine_edit_issues_inline     1.0b
  redmine_indicator              0.2.16
  redmine_issues_plus            0.3.0
  redmine_my_page_paginations    1.0.2_1
  redmine_searchable_selectbox   0.1.11
  redmine_subproject_collapse    0.2.0
  redmine_whining                0.0.4_4

z j5 个月 之前添加

@guo hongxing 我的redmine版本是 5.0.2,官网上拉取的版本

redmineplugins.cn Admin5 个月 之前添加

z j 你好, redmine_my_page_paginations-1.0.3_1.zip 修复版本已邮件发送给你,方便时请查收。

guo hongxing5 个月 之前添加

z j 好的,我用5.0.2试试看

z j5 个月 之前添加

@guo hongxing 已收到,问题已解决,感谢

guo hongxing5 个月 之前添加

z j 你的redmine的具体版本号是什么?

zou hp超过一年 之前添加

可以升级支持5.x版本么?

redmineplugins.cn Admin超过一年 之前添加

@zou hp 需要修改下,重新适配redmine5。随后再上传一个版本。

XIAO Sam超过 3 年 之前添加

我在 Redmine-4.1.1 /Ubuntu20.04.2LTS中可以用
Redmine My Page Paginations 1.0.2

XIAO Sam超过 3 年 之前添加

我在 Redmine-4.1.1 /Ubuntu20.04.2LTS中可以用

redmineplugins.cn Admin大约 4 年 之前添加

谢谢,更新到1.0.2了

Zhang nicsun大约 4 年 之前添加

bitnami~4.1也用不了,不过github上面的可以,链接参考https://github.com/HugoHasenbein/redmine_my_page_paginations

由 匿名用户 在 超过 4 年 之前添加

插件目录名要去掉版本号

redmineplugins.cn Admin超过 4 年 之前添加

redmine4.*吗,我试一下!

由 匿名用户 在 超过 4 年 之前添加

你的redmine版本是所少?

由 匿名用户 在 超过 4 年 之前添加

下载了,不能用,直接我的工作台都打不开了