项目

一般

简介

运行bundle update报错“Failed to build gem native extension”,如何解决?

0

xu renfeng
大约一个月 之前增加

安装插件时,运行bundle install,提示要运行bundle update,结果运行update时,报错“Failed to build gem native extension”。如下图所示:

解答 (1)

-1

Chen Snowman
大约一个月 之前增加

试试:

Ubuntu 或 Debian-based 环境:

sudo apt-get install build-essential ruby-dev

Fedora, Red Hat, CentOS 环境:

dnf install -y make gcc rpm-build ruby-devel

已解决,非常感谢大佬的指点

    (1-1/1)