项目

一般

简介

插件目录 » Redmine Issue Autoflow 问题流程审批插件

评论

添加评论

#1 Admin Redmine大约一个月 之前添加

@邓慧 Redmine Issue Autoflow的demo版还可以下载试用吗?

暂不提供演示版下载了,可以在 https://free-demo.saas.craftmine.pro/projects/test 在线试用,或者到 https://www.craftmine.pro/redmine-hostings/ 申请redmine虚拟主机试用

#2 慧 邓大约一个月 之前添加

Redmine Issue Autoflow的demo版还可以下载试用吗?

#3 Admin Redmine大约 2 个月 之前添加

@Chang Uart 第2封邮件发给你了,请再查收下。

#4 Chang Uart大约 2 个月 之前添加

我有写信去询问如何购买及价钱, 不过一直没收到回覆关于要如何购买.

#5 Admin Redmine2 个月 之前添加

@Chang Uart Redmine Issue Autoflow为收费插件,如有购买需求请发邮件至

#6 Chang Uart2 个月 之前添加

请问要在哪里下载? Redmine 4.1.1使用.

#7 Admin Redmine3 个月 之前添加

建议添加一个功能,可以设置某个流程与某个跟踪标签自动绑定,不需要手工选择模板

但通常同一个跟踪标签也会使用到不同的流程,不是吗?

#8 由 匿名用户 在 3 个月 之前添加

建议添加一个功能,可以设置某个流程与某个跟踪标签自动绑定,不需要手工选择模板

#9 Admin Redmine3 个月 之前添加

gems安装正常,不是错误提示

#10 yin xiaobo3 个月 之前添加

执行bundle install,出现如下结果
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this application for all non-root
users on this machine.
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
The dependency ffi (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
Using rake 13.0.1
。。。(中间是安装的gems)
Using rouge 3.12.0
Bundle complete! 35 Gemfile dependencies, 67 gems now installed.
Gems in the groups development, test and sqlite were not installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.

#11 Admin Redmine4 个月 之前添加

执行下面命令后再试试 bundle install

sudo apt-get update
sudo apt-get install build-essential

#12 由 匿名用户 在 4 个月 之前添加

那就是你执行了bundle install,但没有执行成功。你可以把执行后的结果提交下

#13 由 匿名用户 在 4 个月 之前添加

执行bundle install出现下面的问题:
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory: /usr/local/bundle/gems/debug_inspector-0.0.3/ext/debug_inspector
/usr/local/bin/ruby -I /usr/local/lib/ruby/2.6.0 -r ./siteconf20200612-55-fp2how.rb extconf.rb
creating Makefile

current directory: /usr/local/bundle/gems/debug_inspector-0.0.3/ext/debug_inspector
make "DESTDIR=" clean
sh: 1: make: not found

current directory: /usr/local/bundle/gems/debug_inspector-0.0.3/ext/debug_inspector
make "DESTDIR="
sh: 1: make: not found

make failed, exit code 127

Gem files will remain installed in /usr/local/bundle/gems/debug_inspector-0.0.3 for inspection.
Results logged to /usr/local/bundle/extensions/x86_64-linux/2.6.0/debug_inspector-0.0.3/gem_make.out

An error occurred while installing debug_inspector (0.0.3), and Bundler cannot continue.
Make sure that `gem install debug_inspector -v '0.0.3' --source 'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
binding_of_caller was resolved to 0.8.0, which depends on

#14 由 匿名用户 在 4 个月 之前添加

"你好,需要先执行bundle install "

已经执行过了,还是报错

#15 Admin Redmine4 个月 之前添加

你好,需要先执行bundle install

#16 由 匿名用户 在 4 个月 之前添加

安装插件报错:
Could not find gem 'rgl’ in any of the gem sources listed in your Gemfile.

#17 Admin Redmine4 个月 之前添加

不确定插件是否安装成功,数据库迁移正常吗?
bundle exec rake redmine:plugins:migrate NAME=redmine_issue_autoflow

可以提交个问题,把报错日志传上去 https://redmineplugins.cn/projects/redmineplugins/issues/new

#18 yin xiaobo4 个月 之前添加

安装完成,审批节点 新建时页面报错
Page not found
The page you were trying to access doesn't exist or has been removed.

Back

#19 yin xiaobo4 个月 之前添加

是我版本弄错了,难怪的

#20 yin xiaobo4 个月 之前添加

centos7 执行bundle exec rake的时候报错
版本:bitname-redmine4.1.0-9

RAILS_ENV=production bundle exec rake redmine:plugins:migrate NAME=redmine_issue_autoflow_demo_3.3.2
(in /opt/redmine-4.1.0-9/apps/redmine/htdocs)
rake aborted!
RGLoaderError: RubyEncoder Loader - This protected script requires the redmine_issue_autoflow_2.3.1_demo.lic license file in order to run. Contact the author of the script to get a license file. Error code [13]
/opt/redmine-4.1.0-9/apps/redmine/htdocs/plugins/redmine_issue_autoflow/lib/redmine_issue_autoflow/redmine_issue_autoflow.rb:2:in `RGLoader_load'
/opt/redmine-4.1.0-9/apps/redmine/htdocs/plugins/redmine_issue_autoflow/lib/redmine_issue_autoflow/redmine_issue_autoflow.rb:2:in `<top (required)>'

#21 Admin Redmine4 个月 之前添加

正式版需求请发邮件至

#22 由 匿名用户 在 4 个月 之前添加

正式版收费吗?

#23 Admin Redmine5 个月 之前添加

拒绝和未决等状态是流程某个节点的审批决议,不是issue的状态。issue所绑定的流程在审批过程中会存在多次同意、拒绝,因此issue的过滤器无法去检索哪次同意或拒绝。但,流程节点可以设置为与issue的状态联动,例如可以将流程节点与问题/issue的联动状态设置为"处理中"、"待反馈"等状态。

#24 Mok Louie5 个月 之前添加

如何在过滤器中選出巳拒绝或未决不同状态的工单?

#25 Admin Redmine5 个月 之前添加

demo支持两个流程模版,正式版没有限制

#26 cxszhao cxs5 个月 之前添加

demo和正式版区别在哪里?

#27 Admin Redmine7 个月 之前添加

问题流程审批插件-2.1.3现在可以下载了

#28 由 匿名用户 在 7 个月 之前添加

  • 获取试用版请提供Redmine的版本号、服务器操作系统类型(windows/linux)以及服务器主机的MAC地址和IP地址
  • 将上述信息发邮件至

#29 李 清民7 个月 之前添加

这个插件有开源版吗? 如何获得?

#30 由 匿名用户 在 7 个月 之前添加

添加评论